Actualización de WordPress 2.9 fallida

El pasado dí­a 19 de diciembre se liberó la ansiada actualización de WordPress 2.9 y su traducción al español. Pues bien, parece que hubo un número de fallos que han provocado incluso la caí­da de varios blogs que han tenido que tirar de copias de seguridad -los que las hicieron- para poder recuperar y dejar todo como estaba.

El principal fallo que nos encontramos los que actualizamos a la versión en español es que, una vez aplicada la actualización, nos quedaba una página totalmente en blanco. Una vez investigado el fallo parece ser que era un problema de alguna función y que sólo ocurrí­a a aquellos que actualizamos desde esta traducción, ya que los que actualizaron desde la versión original en inglés, si aplicaban después el parche de traducción al español no encontraban ningún problema. Por eso la solución primera era subir por ftp la versión en inglés y a continuación subir los ficheros de traducción y modifiar config.php para activar el idioma es_ES. Algún bloguero más avezado –Hector Bení­tez– descubrió después de investigar que el problema parecí­a deberse a una mala actualización de la versión en español del fichero functions.php, por lo que subiendo este fichero desde la versión original a su lugar en el directorio wp-includes se solucionaba el problema. Está explicado en su blog.

Pues nada, que hoy según publica ayudawordpress y gracias a que Semiologic ha encontrado 3 fallos nuevos en WordPress 2.9 y que a la espera de una nueva versión que los solucione -una posible versión 2.9.1– proponen sus propios parches:

Como resultado de estos errores nos encontramos con:

  • Widget RSS que fallan tanto en el escritorio como en las barras laterales y
  • Artí­culos programados que no llegan a publicarse nunca.

No todos los blog se ven afectados por ello, pero para aquellos que sí­ lo son es fustrante. El parche, una vez descomprimido el fichero, consiste en sustituir los ficheros que contiene por los mismos en wp-includes. Estos ficheros son: class-simplepie.php, default-widgets.php y http.php.

¡¡ AVISO !!

Yo efectivamente tení­a problemas con algunos widget de uno de mis blogs –Estampas de Madrid– de modo que incluso he tenido que cambiar el tema que antes compartí­a con este blog, pero que, una vez actualizado a la 2.9 quedó hecho unos zorros -incluido el fallo de página en blanco solucionado, tal y como indico arriba, subiendo los archivos en inglés y aplicando el parche de idioma- y que finalmente he tenido que rehacer modificando el logo, desactivando plugins que no funcionan como antes y recolocando los widgets del lateral. Como decí­a, como tení­a esos problemas aplique los parches que recomienda Semiologic y me encontré de nuevo con una página en blanco. Por lo tanto, recomiendo encarecidamente hacer copia de seguridad de esos ficheros antes de sustituirlos e, incluso, copia de seguridad total o esperarse a la próxima actualización por si soluciona estos problemas y no provoca otros.

Yo por si acaso, hasta que no tenga las cosas claras, mis otros tres blogs los dejo en la 2.8.6, que me están funcionando tan ricamente.

También te puede interesar:

Escaños en Blanco Sevilla. ¡Mándales a la mierda!
Curioso ví­deo este sobre el voto en blanco en las...
Un ilusión curiosa
En la página de Mighty Optical Illusions encontré esta curiosa...
Y son del mismo partido
Y la verdad es que acojona. Lo escuchado esta ultima...
El rey se va, Rubalcaba no se entera
Pues hoy le ha dado aquí­ al Juancar por decir...

Send this to a friend